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Foreword 

In this section the following information is included: 

• About this User Guide and Help 
• Terminology 
• Side Headings 
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About this User Guide and Help 
The InForm Filler user guide and Help provide detailed instruction about 
how to operate InForm Filler; from installation and configuration, to 
viewing, filling in and publishing forms, they are designed as an everyday 
reference for both beginners and experts. 

The user guide and Help assume you have a working knowledge of the 
Windows® operating system and its conventions, including how to use a 
mouse and keyboard, and how to run applications from the desktop or 
Start menu. For help with any of these techniques, please refer to your 
Windows® documentation or help. 

Printing 

The InForm Filler Help is primarily designed for on-screen reference. Even 
though its content can be printed, it is the InForm Filler user guide 
(InForm_Filler_User_Guide.pdf) that is better suited for this purpose. 

The layout of the user guide is designed for duplex (back to back) printing. 
If your printer has a duplex facility, please ensure it is set prior to printing. 
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Terminology 
The InForm Filler user guide and Help contain a glossary where common 
terms are described. 

Certain terms are also underlined throughout the user guide and Help. By 
positioning your mouse pointer over one of these links and pressing your 
primary mouse button, one of the following actions occurs… 

• A pop-up description of the term is displayed alongside. 
• A page within the user guide or Help that describes the term or a 

topic relating to it is displayed. 
• A Fly Software web page relating to the term is displayed. 
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Side Headings 
For quick reference, the following side headings are displayed throughout 
the InForm Filler user guide and Help: 

EXAMPLE: 
Provides an example of the current topic. 

NOTE: 
Provides additional information or hints to assist in performing a task or 
understanding the current topic. 

MORE: 
Used to indicate where further details about the current or a related topic 
can be found. 

CAUTION: 
Used if the current action or omission may cause irretrievable results such 
as loss of data.
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Contents 

In this section the following information is included: 

• At a Glance 
• Concise 
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Introduction 

In this section the following information is included: 

• Why You Need InForm Filler 
• What InForm Filler can do for You 
• InForm Documents 
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Why You Need InForm Filler 
If you have filled in a job application form, tax return, financial 
questionnaire, medical certificate or any other electronic or printed 
document, you will already know how demanding and time consuming 
the process can be. 

Poor handwriting and bad spelling, combined with complicated and/or 
expensive form filling, DTP or word-processing software, can all add to the 
problems encountered when filling in a form. 

Even online forms can cause problems: 

• No Internet connection = no form. 
• Lost or temperamental Internet connection and certain firewalls 

prevent form information being transmitted. 
• Form information cannot normally be saved so the form must be 

completed in one sitting. 
• Forms cannot be physically signed by the user which may prevent 

the form being legally binding. 
• Limited security may result in sensitive or personal information 

being viewed by unauthorised personnel and phishers. 

Despite these problems there are software applications available to make 
the process of filling in forms as simple and as painless as possible. InForm 
Filler is one of these applications. 
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What InForm Filler can do for You 
InForm Filler is a Windows® application developed by Fly Software to 
provide a quick, easy and cost effective way of filling in forms created or 
adapted using InForm Designer.  

No longer do you have to painstakingly complete forms by hand, on a 
typewriter, online, or using complicated and expensive software. Just 
download, install and use InForm Filler instead. 

If you don’t already have InForm Filler installed, it can be downloaded for 
free from the Fly Software website. 

http://www.flysoftware.com/
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InForm Documents 
Forms that can be opened, viewed, filled in and printed using InForm Filler 
are called InForm documents. All are designed using Fly Software’s InForm 
Designer and can be recognised by their IFD filename extension and 
distinctive icon (Fig. 1).  

 

Fig. 1 InForm document (IFD) icon 

Normally, InForm documents have a small footprint, making them ideal 
for distribution by email or publication on a website. Alternatively they 
can be printed on plain or pre-printed paper, faxed or converted to PDF (if 
suitable drivers are available). 

Designing Your Own Forms 

If you need to design a form from scratch or have an existing electronic or 
printed form you would like to convert to an InForm document, InForm 
Designer provides all the necessary tools. 

The design tools available in InForm Designer are provided by a 
comprehensive range of components called InForm Plug-ins. Each plug-in 
can be individually purchased and licensed to satisfy your form design 
requirements and keep your software expenditure to a minimum. 

EXAMPLE: 
If all you want to do is use a scanned form as a template, and add text 
boxes so users can enter data electronically, all you need to license within 
InForm Designer is the Text Box InForm Plug-in. 

InForm Designer can be downloaded from the Fly Software website for 
free. It can be freely used to design forms but will contain a watermark 
until all the InForm Plug-ins used to create the form are purchased and 
licensed. 

By using InForm Plug-ins, you are no longer overwhelmed by unnecessary 
design tools (a problem common to most other form design, DTP and 
word-processing applications), and you only ever need to pay for the form 
design functionality you need. 

http://www.flysoftware.com/
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Using Pre-designed Forms 

The following Fly Software web page contains InForm documents which 
can be downloaded and filled in using InForm Filler: 

http://www.flysoftware.com/products/inform_forms/inform_forms.asp 

Businesses and organisations around the world can design and publish 
InForm documents in the knowledge they are accessible by anyone with 
InForm Filler. 

Form Design Service 

Fly Software offer a fast and professional form design service. Visit the 
following Fly Software web page to find out more: 

http://www.flysoftware.com/services/form_design.asp

http://www.flysoftware.com/products/inform_forms/inform_forms.asp
http://www.flysoftware.com/services/form_design.asp
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Getting Started 

In this section the following information is included: 

• System Requirements 
• Installing 
• Launching 
• Workspace Overview 
• Application Menus and Toolbars 
• Context Menus 
• Opening, Closing and Saving Forms 
• Managing Printer Offsets 
• Printing Forms 
• The Fly Software Watermark 
• Improving Performance 
• Displaying Developer and Application Information 
• Leaving Feedback 
• Updating 
• Shutting Down 
• Uninstalling 
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System Requirements 
InForm Filler requires the following minimum computer system 
requirements: 

• Microsoft® Windows® 7, Vista, XP, 2003, 2000, NT 
• Intel® Pentium® or AMD® K6 processor 
• 128 MB of RAM (512 MB recommended) 
• 20 MB of available hard-disk space 
• 800x600 pixel screen resolution 



Getting Started 

InForm Filler User Guide 9 

Installing 
To start the InForm Filler installation process, double-click the InForm 
Filler installation file. Following this, the Installation Wizard is opened 
which guides you through the entire InForm Designer installation. 

NOTE: 
InForm Filler can only be installed when you are logged on to Windows as 
an administrator. 

NOTE: 
Installation can be aborted at any time by clicking the Cancel button. 

Default Install Locations 

InForm Filler’s application files and application data are stored in different 
locations. 

Application Files 

By default, InForm Filler’s application files are installed in the following 
location: 

C:\Program Files\Fly Software\InForm\ 

Application Data 

By default, InForm Filler’s application data, including its configuration file 
(App.ini) and example forms are installed in the following location: 

Windows XP, 2000, 2003 

C:\Documents and Settings\All Users\Application Data\Fly 
Software\InForm 

Windows 7, Vista 

C:\ProgramData\Fly Software\InForm\ 

NOTE: 
The Application Data and ProgramData folders referenced above may be 
hidden from view in Windows Explorer or My Documents. 

MORE: 
To show the Application Data and ProgramData folders, refer to your 
Windows documentation or Help. 
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Obtaining an Installation File 

The InForm Filler installation file (InForm_Filler_Setup.exe) can be 
downloaded from the following Fly Software Web page: 

http://www.flysoftware.com/downloads 

http://www.flysoftware.com/downloads
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Launching 
Launch (run) InForm Filler by clicking the InForm Filler icon (Fig. 2) in the 
Fly Software folder on the Windows® Start Menu. Alternatively, double-
click the InForm Filler icon on the Windows® desktop (if available). 

 

Fig. 2 InForm Filler icon 

Following launch, the application workspace (Fig. 3) appears. 
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Workspace Overview 
When you launch InForm Filler, the application window opens to display 
the workspace (Fig. 3) where components typical to most Windows® 
applications are located.  

 

Fig. 3 InForm Filler workspace 

If an InForm document is open the content of a single page is also 
displayed.  
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Application Menus and Toolbars 
To access InForm Filler’s commands, preferences and tools, the following 
application menus (Fig. 4) and toolbars (Fig. 5) are provided: 

• File 
• Edit 
• View 
• Help 

 

Fig. 4 Application menus and open File menu  

 

Fig. 5 File toolbar 

NOTE: 
Menu options and toolbar buttons displayed in grey indicate the 
associated command or feature is currently unavailable. 

File 

The File menu contains options for performing the following actions: 

• Opening an InForm document 
• Closing an InForm document 
• Saving an InForm document 
• Adding, modifying and deleting printer offsets 
• Printing an InForm document 
• Opening recent InForm documents 
• Shutting down InForm Designer. 

The File toolbar contains buttons for some but not all corresponding 
options. 
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Open 

Displays the Open dialog (Fig. 7) where InForm documents can be 
selected and opened in InForm Filler. 

Keyboard shortcut:  Ctrl+O 

Toolbar button:   

Close 

Closes the open InForm document. If the InForm document has changed 
since it was last saved, a Save confirmation dialog is displayed prior to 
closing. 

Keyboard shortcut:  Ctrl+W 

Toolbar button:  None 

Save 

Saves the open InForm document. 

Keyboard shortcut:  Ctrl+S 

Toolbar button:   

Save As 

Displays the Save As dialog (Fig. 10) where a new filename and location 
for the open InForm document can be specified prior to saving. 

Keyboard shortcut:  Shift+Ctrl+S 

Toolbar button:  None 

Printer Offsets 

Opens the Printer Offsets dialog (Fig. 12) where printer offsets can be 
added, modified and deleted. 

Keyboard shortcut:  None 

Toolbar button:  None 

Print 

Displays the Print dialog (Fig. 16) where action can be taken to select a 
printer and print all or part of the open InForm document. 

Keyboard shortcut:  Ctrl+P 
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Toolbar button:   

Recent Files  

Lists the last five InForm documents to be opened in InForm Filler. 

Keyboard shortcut:  None 

Toolbar button:  None 

Exit 

Exits InForm Filler. If an open InForm document has changed since it was 
last saved, a Save confirmation dialog is displayed before exiting. 

Keyboard shortcut:  Ctrl+Q 

Toolbar button:  None 

NOTE: 
InForm Filler can also be exited using the standard application close (exit) 
button located on the title bar.  

Edit 

The Edit menu and toolbar contain options and buttons for performing 
the following actions: 

• Undoing the last action 
• Redoing the last undone action 
• Cutting text 
• Copying text 
• Pasting text 
• Deleting text 
• Selecting all text 

Undo 

Undoes the last action to be performed on the open InForm document. 

Keyboard shortcut:  Ctrl+Z 

Toolbar button:   

Redo 

Redoes the last action to be undone for the open InForm document. 

Keyboard shortcut:  Shift+Ctrl+Z 
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Toolbar button:   

Cut 

Cuts all selected text and stores it on the Windows® clipboard. 

Keyboard shortcut:  Ctrl+X 

Toolbar button:   

Copy 

Copies all selected text and stores it on the Windows® clipboard. 

Keyboard shortcut:  Ctrl+C 

Toolbar button:   

Paste 

Pastes the last cut or copied text into the selected form element. 

Keyboard shortcut:  Ctrl+V 

Toolbar button:   

Delete 

Deletes all selected text. 

Keyboard shortcut:  Delete/Del 

Toolbar button:   

Select All 

Selects all text from the selected form element. 

Keyboard shortcut:  Ctrl+A 

Toolbar button:   

View 

The View menu contains options for performing the following actions: 

• Displaying the actual page size 
• Fitting the page width in the workspace 
• Fitting the entire page in the workspace 
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• Resetting the form 
• Validating the form 
• Turning PDF quick draw on and off 
• Turning flicker reduction on and off 
• Turning form element hints on and off 
• Turning application toolbars on and off 

The View toolbar contains buttons for some but not all corresponding 
options. It also contains additional components and buttons used for: 

• Displaying the current page zoom 
• Manually changing the page zoom 
• Selecting a predetermined page zoom 

Actual Size 

Resizes the view of the current page to actual size. 

Keyboard shortcut:  F7 

Toolbar button:   

Fit to Width 

Resizes the view of the current page to fit the width of the application 
window. 

Keyboard shortcut:  F8 

Toolbar button:   

Fit to Page 

Resizes the view of the current page to fit entirely within the application 
window. 

Keyboard shortcut:  F9 

Toolbar button:   

Reset Form 

Resets applicable form elements to a default value or state. 

Keyboard shortcut:  None 

Toolbar button:   



Getting Started 

18 InForm Filler User Guide 

Validate Form 

Checks validation conditions for applicable form elements. 

Keyboard shortcut:  None 

Toolbar button:   

PDF Quick Draw 

Determines whether PDF quick draw is turned on or off. When turned on 
slow display of PDF backgrounds or form elements is less evident. 

Keyboard shortcut:  None 

Toolbar button:  None 

Flicker Reduction 

Determines whether flicker reduction is turned on or off. When turned on 
any screen flicker experienced is less evident. 

Keyboard shortcut:  None 

Toolbar button:  None 

Hints 

Determines whether hints are displayed when the mouse pointer is 
positioned over form elements. 

Keyboard shortcut:  None 

Toolbar button:  None 

Toolbars 

Determines what application toolbars are displayed. 

Keyboard shortcut:  None 

Toolbar button:  None 

Current Zoom 

Displays the zoom level of the current page view in percent. 

Keyboard shortcut:  None 

Toolbar image:  
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NOTE: 
Only found on the toolbar.  

Manual Zoom 

Magnifies or reduces the current page view between 1% and 800% in 1% 
increments. 

Keyboard shortcut:  None 

Toolbar button:   

NOTE: 
Only found on the toolbar.  

Zoom Presets 

Lists and allows you to select predetermined page views between 25% 
and 800%. 

Keyboard shortcut:  None 

Toolbar button:   

NOTE: 
Only found on the toolbar.  

Help 

The Help menu and toolbar contain options and buttons for performing 
the following actions: 

• Displaying help 
• Displaying developer and application information 
• Providing feedback about InForm Filler 
• Updating InForm Filler 
• Visiting the Fly Software home page 

Help 

Displays the InForm Filler help. 

Keyboard shortcut:  F1* 

Toolbar button:   

*NOTE: 
Pressing the F1 key when certain workspace objects and are focused, 
displays context help for that. 
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About InForm Filler 

Displays the About dialog where developer information and the 
application version number are shown. 

Keyboard shortcut:  None 

Toolbar button:   

Leave Feedback 

Opens the Feedback Form on the Fly Software website where comments 
about InForm Filler can be completed and sent to Fly Software.  

Keyboard shortcut:  None 

Toolbar button:  None 

Update InForm Filler 

Displays the Update dialog where updates for InForm Filler can be 
selected, downloaded and installed.  

NOTE: 
Requires an Internet connection. 

Keyboard shortcut:  None 

Toolbar button:   

Fly Software Online 

Opens a browser window to display the Fly Software Home page.  

NOTE: 
Requires an Internet connection 

Keyboard shortcut:  None 

Toolbar button:   

Showing and Hiding Toolbars 

By default, all application toolbars are displayed in InForm Filler. However, 
if you rarely use a particular toolbar, would like to make room for 
displaying more of your InForm document, or prefer to use the application 
menus, each toolbar can be turned off (and on again if required). 

Select View >Toolbars to display a fly-out menu listing all available 
toolbars. 
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Select an option to either remove the associated tick and hide the toolbar, 
or add a tick and show the toolbar. 
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Context Menus 
Context menus (Fig. 6) display commands for the form element located 
under the mouse pointer.  

 

Fig. 6 Context menu 

You can view a context menu for any form element that has one by right-
clicking it. If available, the menu is displayed next to the mouse pointer. 

NOTE: 
Menu options and toolbar buttons displayed in grey indicate the 
associated command is currently unavailable. 

NOTE: 
Context menus are limited to text-based form elements such as text 
boxes, and allow common edit operations such as cut, copy and paste, to 
be performed. 

MORE: 
For details about the edit options displayed on context menus, refer to 
Application Menus and Toolbars > Edit. 
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Opening, Closing and Saving Forms 
InForm Filler opens and can subsequently save and close InForm 
documents.  

Open 

To open an InForm document click the Open button or select File > Open. 
Following this an Open dialog (Fig. 7) is displayed where you can select an 
InForm document from your file system. 

 

Fig. 7 Open dialog 

If an InForm document you would like to use is one of the last five opened, 
it can be opened again by selecting it from the recent files list displayed 
on the File menu. 

You can also open an InForm document outside of InForm Filler by 
double-clicking its filename or file icon (Fig. 1) in your file management 
application (e.g. Windows® Explorer), email application (e.g. Outlook) or 
from a page displayed in your Web browser (e.g. Internet Explorer). 

After opening an InForm document, the first page is displayed by default. 

NOTE: 
Only one InForm document can be opened per instance of InForm Filler.  If 
more than one needs to be opened, another instance of InForm Filler will 
need to be launched. 
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Unrecognised Form Element(s)  

An InForm document cannot be opened if it contains one or more form 
elements InForm Filler does not recognise. When this occurs a Form 
Element(s) Not Found dialog (Fig. 8) is displayed. 

 

Fig. 8 Form Element(s) Not Recognised dialog 

To open a problematic InForm document, install the latest InForm Filler 
and try again. 

Unrecognised Properties 

If an InForm document uses a form element that contains properties that 
are no longer available, it cannot be opened and a Properties Not 
Recognised dialog (Fig. 9) is opened. 

 

Fig. 9 Properties Not Recognised dialog 

To open the problematic InForm document, shutdown then install the 
latest InForm Filler and try again. 
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Close 

To close an open InForm document select File > Close.  After closing, the 
application window remains displayed. 

NOTE: 
If an InForm document has not been saved since changes were last made, 
a Save Changes confirmation dialog is displayed prior to closing. 

Save 

To retain form information you have filled in, you must save your InForm 
document.  

Click the Save button or select File > Save. 

If the InForm document has been saved before, the current content will 
overwrite the previously saved content. 

NOTE: 
If the InForm document has not been saved before, a Save As dialog (Fig. 
10) is opened where a file name and folder location can be specified. 

Save As 

To give an open InForm document a new filename (and as a result retain 
the previous save state), select File > Save As. This opens a Save As dialog 
(Fig. 10) where a new filename and folder location can be specified. 

 

Fig. 10 Save As dialog 
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NOTE: 
Following a Save As, the InForm document that remains open is the newly 
saved one. 
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Managing Printer Offsets 
It is common for different makes and models of printer to position printed 
content slightly differently. This is not normally a problem when printing 
InForm documents on plain paper, but if filled in content is printed on pre-
printed forms the differences in positioning can be unacceptable. 

 

Fig. 11 Example of misaligned form content on a pre-printed form 

To overcome the problem of printers positioning printed content 
differently, printer offsets can be defined so the entire printed content is 
moved horizontally and/or vertically on a page. 

EXAMPLE: 
If printed form content is misaligned by 3mm to the left and 2mm up for a 
particular printer, a printer offset that moves the printed content 3mm to 
the right and 2mm down is required for that printer. 

To add, modify and delete printer offsets select File > Printer Offsets. 
Following this, a Printer Offsets dialog (Fig. 12) is opened. 

 

Fig. 12 Printer Offsets dialog 

Click the Close button to close the Printer Offsets dialog. 
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MORE: 
For details about how to select a printer offset or specify one manually 
prior to printing, refer to Printing Forms > Using a Printer Offset. 

Adding 

To add a printer offset click the New button in the Printer Offsets dialog 
(Fig. 12). Following this, an Add Printer Offset dialog (Fig. 13) is opened.  

 

Fig. 13 Add Printer Offset dialog 

To configure a printer offset, perform the following actions: 

1. Click the Printer drop-down list then click the name of the printer 
the printer offset is required for. 

2. In the Offset Name edit box, type a name for the printer offset. This 
will be used to identify the printer offset within InForm Designer 
and InForm Filler. 

3. In the X Offset edit box type the number of millimetres (mm) 
printed content will be moved along the horizontal (x) axis of a 
page. A negative value moves printed content to the left, a positive 
value moves printed content to the right. 

4. In the Y Offset edit box type the number of millimetres (mm) 
printed content will be moved along the vertical (y) axis of a page. 
A negative value moves printed content up, a positive value moves 
printed content down. 

5. Click the OK button to add the printer offset and close the Add 
Printer dialog. 

Modifying 

To modify a printer offset click the name of the printer offset then the Edit 
button in the Printer Offsets dialog (Fig. 12). Following this, a Modify 
Printer Offset dialog (Fig. 14) is opened. 
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Fig. 14 Modify Printer Offset dialog 

Modify necessary settings in the same way as you add a printer offset then 
click the OK button. 

Deleting 

To delete a printer offset click the name of the printer offset then click the 
Delete button in the Printer Offsets dialog (Fig. 12). Following this, a 
Confirmation dialog (Fig. 15) is opened asking you to confirm the delete. 

 

Fig. 15 Delete Printer Offset Confirmation dialog 

Click the Yes button to confirm the delete or the No button to cancel. 
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Printing Forms 
Like most Windows applications, InForm Filler has a print facility. This 
enables InForm documents to be output on a printer, transmitted by fax, 
or converted to another file format such as XPS or PDF (if suitable drivers 
are installed). 

To begin printing, open the InForm document you wish to print then click 
the Print button, or click File > Print. Following this, the Print dialog (Fig. 
16) is opened. 

 

Fig. 16 Print dialog 

Click a printer in the Name drop down list, and if necessary configure it by 
clicking the Properties button. Specify the number of copies and the 
page(s) to print then click the OK button. 

Click the Cancel button to cancel printing and return to your InForm 
document.  

NOTE: 
When transmitting by fax or converting to another file format, further 
dialogs are likely to appear that require additional input. Follow the 
instructions provided within these dialogs to complete the associated 
process. 

NOTE: 
If validation fails for one or more form elements, the Validation Failed 
dialog (Fig. 33) appears prior to opening the Print dialog. 
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Using a Printer Offset 

If one or more printer offsets have been added for an InForm Filler 
installation, a Select Printer Offset dialog (Fig. 17) is opened after clicking 
the OK button in the Print dialog (Fig. 16). 

 

Fig. 17 Select Printer Offset dialog 

The Select Printer Offset dialog enables you to use a saved printer offset, 
specify a manual printer offset or ignore printer offsets completely. 

Click the Cancel button to close the Select Printer offset dialog, cancel 
printing and return to your InForm document. 

MORE: 
For further details about printer offsets and how to add, modify and 
delete them, refer to Getting Started > Managing Printer Offsets. 

Using a Saved Printer Offset 

If the printer selected in the Print dialog (Fig. 16) has an associated printer 
offset, the name of the printer offset is highlighted (in bold) in the Saved 
Offsets list of the Select Printer Offset dialog (Fig. 17). It is preferable that a 
highlighted printer offset is used but any one can be selected and used 
instead. 

Click the name of the printer offset you wish to use, confirm the X and Y 
offsets displayed below the Saved Offsets list are suitable then click the OK 
button. Following this the Select Printer Offset dialog is closed and the 
InForm document is printed using the selected printer offset. 
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Specifying a Manual Printer Offset 

If you prefer to configure and use a manual (bespoke) printer offset 
instead of a saved one, specify the X and Y offset values in millimetres 
(mm) in the Select Printer Offset dialog (Fig. 17). Following this, click the 
Use Manual Offsets checkbox to enable the manual settings and disable 
the printer offsets in the Saved Offsets list. 

Click the OK button to close the Select Printer Offset dialog and print the 
InForm document using the specified manual printer offset. 

Ignoring Printer Offsets 

To print an InForm document without applying a printer offset, click the 
Ignore offsets checkbox in the Select Printer Offset dialog (Fig. 17). 

Click the OK button to close the Select Printer Offset dialog and print the 
InForm document. 

Print Results 

Print results replicate exactly what you see on the screen. However, only 
form elements, certain components of form elements, page backgrounds 
and pages configured for publishing are output*.  

*NOTE: 
Configuration of form elements, page backgrounds and pages for 
publishing is determined by the form designer. 

Printer Properties that are Ignored 

If an InForm document is not published as expected, it may be due to 
certain page/paper properties for the selected printer being ignored. This 
is because the paper size and orientation properties of each page take 
precedence over corresponding printer properties. 

EXAMPLE: 
If the orientation of a page is landscape, and the orientation of the printer 
is portrait, the page is printed in landscape. 



Getting Started 

InForm Filler User Guide 33 

The Fly Software Watermark  
If the pages of an InForm document display a Fly Software watermark (Fig. 
18), the InForm document was designed using an installation of InForm 
Designer that used at least one unlicensed InForm Plug-in.  

 

Fig. 18 Fly Software watermark 

To remove a watermark, contact the form designer or save the InForm 
document using a licensed installation of InForm Designer. 

MORE: 
For details about using InForm Designer to remove the watermark, refer to 
the InForm Designer user guide or help. 
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Improving Performance 
If InForm Designer is installed on a computer with minimum system 
requirements or similar, you may notice the speed at which pages that 
contain PDF backgrounds or form elements are unacceptably slow. 

To increase the speed at which pages containing PDF are displayed, a PDF 
Quick Draw option is provided. By default, this option is turned off but can 
be turned on at any time if required. 

Select View > PDF Quick Draw to add a tick and turn the option on, or 
remove the tick and turn the option off. 

NOTE: 
If PDF quick draw is on, the quality of PDF page backgrounds and form 
elements is reduced. This reduction in quality is not evident when an 
InForm document is printed. 
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Displaying Developer and Application 
Information 

Information about Fly Software, copyright notices and InForm Filler’s 
version number, can be viewed on the Welcome screen when the 
application is launched, or at any time in the About dialog (Fig. 19). 

 

Fig. 19 About dialog 

To display the About dialog, click the About InForm Filler button, or select 
Help > About InForm Filler. 

Click the OK button to close the About dialog. 
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Leaving Feedback 
To help Fly Software improve InForm Filler, feedback is welcomed. 

Your comments about InForm Filler can be conveniently emailed to Fly 
Software using the Feedback Form on the Fly Software website. This is 
opened by clicking Help > Leave Feedback within InForm Filler or 
specifying the following URL in your Internet browser:  

http://www.flysoftware.com/support/feedback.asp 

NOTE: 
Prior to shutting down, BETA versions of InForm Filler automatically open 
the Feedback Form within your Internet browser. 

http://www.flysoftware.com/support/feedback.asp
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Updating 
InForm Filler is continually being developed. As a result, new versions will 
become available that introduce new features and improve existing ones. 

To avoid technical difficulties and to benefit from the latest 
enhancements, it is advised you update your InForm Filler installation 
regularly. 

For convenience, you can open the download page on the Fly Software 
website by clicking Help > Updates, or by specifying the following URL in 
your Internet browser: 

http://www.flysoftware.com/downloads/downloads.asp 

Updating InForm Filler is performed in the same way as installing it. 

http://www.flysoftware.com/downloads/downloads.asp
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Shutting Down 
Shutdown (Exit) InForm Filler by selecting File > Exit.  

NOTE: 
InForm Filler can also be shutdown using the standard application close 
(exit) button on the title bar. 

NOTE: 
If an InForm document is open and has not been saved since changes 
were last made, a Save Changes confirmation dialog is displayed prior to 
shutting down. 
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Uninstalling 
If you no longer wish to use InForm Filler and would like to remove it from 
your computer, it can be uninstalled. 

NOTE: 
Before InForm Filler can be uninstalled, it must first be shutdown. 

InForm Filler is uninstalled using the Windows® Add/Remove Programs 
facility. 

MORE: 
For details about the Windows® Add/Remove Programs facility, refer to 
your Windows® documentation or help. 

NOTE: 
The Fly Software folder remains following uninstall. 
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Viewing Forms 

In this section the following information is included: 

• Changing Pages 
• Magnifying or Reducing the Page View 
• Moving About a Page 
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Changing Pages 
After opening an InForm document, the first page is displayed by default. 
However, many forms have multiple pages that must be read and filled in. 

The page bar (Fig. 20) displays buttons for all pages within the open 
InForm document. A button that is “pressed” indicates the current page. 

 

Fig. 20 Page bar 

Click a page button to display the content of that page. 

NOTE: 
If the page buttons exceed the length of the page bar, navigation arrows 
are provided to allow you to display those that are not shown. Click the 
right arrow to move one page button to the right, and click the left arrow 
to move one page button to the left. 
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Magnifying or Reducing the Page View 
Depending upon your personal preference, or the resolution of your 
monitor, you may want to magnify or reduce the current page view. This 
can be achieved with predetermined page views, and using the mouse 
and keyboard. 

NOTE: 
The default page view used for each page when an InForm document is 
opened is determined by the designer. This means changes you make to 
page views may not be retained when an InForm document is reopened.  

NOTE: 
Changing the page view only changes how it is displayed on screen, and 
does not affect the “physical” or publishable size of the InForm document. 

Predetermined Page Views 

The following predetermined page views are provided to allow you to 
quickly change the current page view: 

• Actual Size 
• Fit to Width 
• Fit to Page 
• Zoom Presets 

Using the Mouse and Keyboard 

If your mouse has a wheel button, you can quickly and conveniently resize 
the page view.  

Make sure no form elements are selected (by clicking the page or pressing 
the Esc key), hold the Ctrl key and roll the wheel button up to zoom in, 
and down to zoom out. 



Viewing Forms 

44 InForm Filler User Guide 

Moving About a Page 
Certain magnification levels may prevent parts of a page being visible 
within the workspace. When this occurs, you may need to move the page 
to display the hidden areas. This can be achieved using scroll bars (Fig. 21), 
the mouse or the keyboard. 

Using Scroll Bars 

When the size of a page exceeds the size of the workspace, vertical and/or 
horizontal scroll bars (Fig. 21) appear. 

Scroll bars allow you to move the viewable area of a page, up, down, left 
and right. Each scroll bar consists of a number of components that move 
the page in a particular way. 

 

Fig. 21 Scroll bar (horizontal)  

Arrows 

Click an arrow to move the page (and scroll bar slider) in the direction of 
the arrow. 

Slider 

Click the slider, hold the primary mouse button then move the mouse to 
move the page (and scroll bar slider).  

Slide Bar 

Click anywhere on the slide bar to move the page (and the scroll bar 
slider).  

Using the Mouse 

If your mouse has a wheel button, roll it up to move the page up, and 
down to move the page down. 

Using the Keyboard 

Press the Page Up button to move the page up, and the Page Down 
button to move the page down. 
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Filling in Forms 

In this section the following information is provided: 

• Interactive Form Elements 
• Selecting Form Elements 
• Using Form Elements 
• Resetting 
• Validating 
• Undo and Redo 
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Interactive Form Elements 
When filling in InForm documents you will be able to interact with one or 
more of the following form elements: 

• Button 
• Check Box 
• Combo Box 
• Date Box 
• Image 
• Radio Button 
• Text Box 
• Time Box 

Button 

A button (Fig. 22) is an interactive form element, that when clicked, can 
perform one of the following pre-determined operations: 

• Perform file operations like opening, closing and saving an InForm 
document. 

• Print an InForm document. 
• Validate the contents of an InForm document. 
• Reset the contents of an InForm document. 
• Navigate pages within an InForm document. 
• Resize the view of a page. 
• Open a URL in an Internet browser. 
• Post the contents of an InForm document to a URL and display 

response data. 
• Email a message and optional attachments (including the current 

InForm document) to a pre-determined or user defined email 
account. 

• Exit InForm Filler. 
• Launch an application. 

 

Fig. 22 Example buttons 

Buttons normally contain a label to indicate what operation they perform. 

EXAMPLE: 
A button that prints an InForm document will normally contain a label 
called “Print”.  
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Check Box 

A check box (Fig. 23) is an interactive form element, that when clicked, 
adds or removes a symbol such as a tick or cross. 

 

Fig. 23 Example check box  

Check boxes are commonly used within an InForm document to indicate 
something is selected or answered positively. 

Combo Box 

A combo box (Fig. 24) is an interactive form element that combines a list 
box and a single-line text box. 

 

Fig. 24 Example combo box 

Check boxes allow you to perform one or both of the following actions: 

• Type a value directly into the control. 
• Choose from a list of existing options. 

MORE: 
For details about using combo boxes, refer to Filling in Forms > Using 
Form Elements > Working with Text and Selecting Options from a Combo 
Box. 

Date Box 

A date box (Fig. 25) is an interactive form element that only allows a date 
in a predetermined format to be specified. 

 

Fig. 25 Example date box 
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Normally a date box will have a label or a hint to indicate the date format 
that must be used. 

MORE: 
For details about using date boxes, refer to Filling in Forms > Using Form 
Elements > Working with Text. 

Image 

An image (Fig. 26) is an interactive form element (and also a non-
interactive form element) that allows an image such as a photograph or 
signature to be selected then added to an InForm document. 

  

Fig. 26 Example images 

MORE: 
For details about adding images, refer to Filling in Forms > Using Form 
Elements > Adding an Image. 

MORE: 
For details about supported image formats, refer to Filling in Forms > 
Using Form Elements > Adding an Image > Supported Image Formats. 

Radio Button 

A radio button (Fig. 27) is an interactive form element that, when clicked, 
adds a symbol such as a dot while simultaneously removing the symbol of 
another radio button in the same group. 

 

Fig. 27 Example radio buttons 

Radio buttons are commonly used within an InForm to indicate an 
exclusive yes or no choice. 

MORE: 
For details about using radio buttons, refer to Filling in Forms > 
Automated Form Elements. 
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Text Box 

A text box (Fig. 28) is an interactive form element that can be used for 
typing or writing text-based information such as a name, email, password 
or numeric value. 

 

Fig. 28 Example text box 

MORE: 
For details about using text boxes, refer to Filling in Forms > Using Form 
Elements > Working with Text. 

Time Box 

A time box (Fig. 29) is an interactive form element that only allows a time 
in a predetermined format to be specified. 

 

Fig. 29 Example time box 

Normally a time box will have a label or a hint to indicate the time format 
that must be used. 

MORE: 
For details about using time boxes, refer to Filling in Forms > Using Form 
Elements > Working with Text. 
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Selecting Form Elements 
Unless you use InForm Filler to simply open and print InForm documents 
(so they can be filled in by hand or on a typewriter) it will be necessary for 
you to interact with certain form elements. 

When an InForm document is opened, a form element will normally be 
selected by default, ready for you to type in text or pick an option. Other 
form elements can be selected using either the mouse or keyboard. 

NOTE: 
A selected form element (Fig. 30) is highlighted by the inclusion of an 
additional border.  

 

Fig. 30 Example selected text box 

MORE: 
For details about interactive form elements you may encounter within an 
InForm document, refer to Filling in Forms > Interactive Form Elements. 

Using the Mouse 

Move the mouse pointer over the form element you wish to select and 
use. When the mouse pointer is in position its shape will normally change 
to reflect the action of the form element. Left-click to select it. 

Using the Keyboard 

As long as a form element is already selected, the keyboard can be used to 
select other form elements. 

NOTE: 
The order in which each form element is selected is determined by the 
form designer.  

NOTE: 
If the next form element in the sequence is on another page, the page will 
automatically change. 

Tab 

Press the Tab key to select the next form element in the sequence.  
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Up and Down Arrows 

Press the Down Arrow key to select the next form element in the 
sequence, and the Up Arrow key to select the previous form element.* 

*NOTE: 
Use of the Up and Down Arrow keys is determined by the form designer. 

Enter 

Press the Enter key to select the next form element in the sequence.* 

*NOTE: 
Use of the Enter key is determined by the form designer. 

Automatic Selection 

Certain form elements such as text boxes may be configured to 
automatically select the next form element in the sequence as soon as the 
current object is filled in or actioned.* This functionality is likely to be most 
evident with form elements requiring serial numbers, dates or other fixed 
length input. 

*NOTE: 
Use of the automatic selection feature is determined by the form designer. 
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Using Form Elements 
Form elements you will encounter when using InForm Filler are intuitive, 
simple to use and do not require detailed instruction. However, for tasks 
and actions that are frequently used, and common to more than one form 
element, instruction is provided.  

MORE: 
If further information about using specific form elements is required, refer 
to the associated InForm Plug-in section within the InForm Designer User 
Guide and Help. 

Working with Text 

Certain form elements such as text boxes (Fig. 28) and combo boxes (Fig. 
24), normally require text entry. If a form element allows text to be typed, 
a flashing cursor is displayed within the form element when it is selected. 

Text can be added in the same way as you add text in a word processing 
or email application. Simply use the keyboard to type the text, and if 
necessary, edit it. 

Common operations such as select all, cut, copy, paste and delete, can all 
be performed on text found in a form element. Use the Edit menu or the 
context menu to perform these operations. 

MORE: 
For further details about selecting and manipulating text, please refer to 
your Windows® documentation or help. 

Font, Style and Alignment 

The font, style and alignment of the text you type are all determined by 
the form designer, and cannot be changed using InForm Filler. 

Changing the Size 

The size of the text that appears within certain form elements can 
sometimes be changed.* 

Making text smaller allows more words and characters to be added to a 
form element. Making it larger results in text that is easier to read. 

Text size is changed in 1pt increments by holding the shift key and rolling 
the mouse wheel button (if available) up to increase the size and down to 
decrease it. 
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CAUTION: 
Increasing text size may result in some or all of the text not being 
displayed within the form element. Similarly, reducing text size may result 
in it becoming unreadable. 

*NOTE: 
The ability to change the size of text within certain form elements is 
determined by the form designer. 

Maximum Words and Characters 

Some forms stipulate maximum word or character limits for certain form 
elements.* This is often apparent if the text entered will be imported into 
a database that has certain field length constraints. 

When the maximum word or character limit is reached, no further text can 
be typed. 

CAUTION: 
If the number of words or characters pasted into a form element exceeds 
the form element’s limit, words or characters exceeding this limit will not 
be added. 

*NOTE: 
Maximum word or character limits are determined by the form designer, 
and cannot be changed using InForm Filler. 

Accepted Text 

Certain form elements only accept text in a pre-determined format.*  

EXAMPLE: 
Most form elements accept regular text such as letters, numbers, symbols 
and spaces, while others may only allow numbers, specific characters or a 
valid date to be entered. 

Normally, if a form element only accepts certain text, it will be labelled 
accordingly on the form. 

*NOTE: 
The text accepted by certain form elements is determined by the form 
designer, and cannot be changed using InForm Filler. 

Required Fields 

Certain form elements may need to be completed prior to printing an 
InForm document. 

MORE: 
For further details, refer to Filling in Forms > Validating. 
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Selecting Options from a Combo Box 

Many InForm documents designed to be filled in electronically, contain 
form elements known as combo boxes (Fig. 24). These allow the form 
designer to predetermine acceptable options, and provide the user with a 
fast and convenient way of selecting them. 

Click the arrow-like button located on the right of a combo box to display 
the options it contains. Click the required option to select and display it. 

Displaying Hidden Options 

Normally, if a combo box contains a large number of options, certain 
options will not be initially displayed. Scroll bars are therefore provided to 
move up and down the list.  

MORE: 
For further details about the principles of using scroll bars, refer to 
Viewing Forms > Moving About a Page > Using Scroll Bars. 

When combo box options are displayed, a letter or number can be typed 
to automatically move to the first option beginning with that letter or 
number (if one exists). 

Adding an Image 

InForm documents may request an image such as a photograph or a 
signature to be added. 

To add a supported image to a page, double-click the area where the 
image needs to be added. Following this, an Image File dialog (Fig. 31) is 
opened where you can browse your file system for an image file. 
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Fig. 31 Image File dialog 

When an image has been located, click it to select it then click the Open 
button to add the content of the image file to the page. 

NOTE: 
Images are automatically resized to fit within the associated area on a 
page. 

Supported Image Formats 

The following image formats are supported: 

• BMP 
• EMF 
• GIF 
• ICO 
• JPG/JPEG 
• PDF 
• PNG  
• WMF 

Automated Form Elements 

Certain form elements change automatically when other form elements 
are manipulated.* 

EXAMPLE: 
A calculation box may automatically calculate and display the sum of 
values specified in text boxes (Fig. 28), while a selected radio button (Fig. 
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27) will become deselected when another in the same radio group is 
selected. 

*NOTE: 
The automated functionality of certain form elements, is determined by 
the form designer, and cannot be changed or disabled using InForm Filler. 
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Resetting 
Certain form elements can be reset to a default value or state by resetting 
the associated InForm document. 

Click the Reset Form button or click View > Reset Form. Following this, a 
Reset Form Confirmation dialog (Fig. 32) is opened asking you to confirm 
the reset. 

 

Fig. 32 Reset Form Confirmation dialog 

Click the Yes button to confirm the reset or the No button to cancel and 
close the dialog. 
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Validating 
Many form elements can have validation applied to them to help ensure 
you complete or select them and/or fill in appropriate content. 

Validation of form elements can occur under the following circumstances: 

Circumstance Description 

While a form element is 
being used 

Certain form elements only accept certain 
characters. Attempting to type an invalid character 
results in nothing appearing within the form 
element. 

When focus is removed 
from a form element 

Remove focus from the form element (i.e. deselect 
the form element or attempt to select another form 
element). If the form element fails validation the 
Validation Error dialog (Fig. 33) appears. 

When printing, 
emailing or posting to a 
URL is performed 

Start the print process, or click a print, email or post 
to URL button in an InForm document. If any form 
element fails validation the Validation Failed dialog 
(Fig. 34) appears. 

When requested 

Click the Validate Form button or View > Validate 
Form, or click a validate form button within an 
InForm document. If any form element fails 
validation the Validation Failed dialog appears. 

 

 

Fig. 33 Validation Error dialog 

 

Fig. 34 Validation Failed dialog 
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Click the OK button to close the Validation Failed dialog or Validation Error 
dialog and return to the InForm document. 
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Undo and Redo 
Any change to the content of a form element can be undone or redone.  

Click the Undo button or select Edit > Undo to undo the last operation 
performed on a form element. 

Click the Redo button or select Edit > Redo to redo the last operation that 
was undone. 

NOTE: 
The number of undo and redo levels is determined by the Windows® 
resources available on the computer where InForm Filler is installed.
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Technical Support and 
Troubleshooting 

In this section the following information is provided: 

• Staying Up-to-date 
• Finding Answers to Common Questions 
• Requesting Support 
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Staying Up-to-date 
One of the best ways to help ensure your experience with InForm Filler is 
problem-free is to keep your installation up-to-date.  

MORE: 
For further details about updating InForm Designer, refer to Getting 
Started > Updating.  
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Finding Answers to Common Questions 
A Knowledge Base, where solutions to common InForm Designer 
questions are provided, can be found on the following Fly Software web 
page: 

http://www.flysoftware.com/support/knowledge_base.asp 

NOTE: 
If you encounter a problem, please refer to the Knowledge Base for a 
solution before requesting support from Fly Software. 

http://www.flysoftware.com/support/knowledge_base.asp
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Requesting Support 
Fly Software operate a support ticket system for anyone who encounters a 
problem using InForm Designer.  

NOTE: 
If you encounter a problem, please consult the Knowledge Base for a 
solution before submitting a support ticket. 

Support tickets can be submitted on the following Fly Software web page: 

http://www.flysoftware.com/user_account/support_form.asp 

NOTE: 
To submit or view support tickets, you must login, or sign-up for a Fly 
Software User Account.

http://www.flysoftware.com/user_account/support_form.asp
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Glossary 

A 

Application Icon 
The graphical image displayed in Windows® that is used for representing a 
software application. When it is clicked or double-clicked, it normally 
launches (opens) the associated application.  

Application Menu 
A menu, common to most Windows® applications, that is normally 
displayed near the top-left of the application window. In InForm Filler, 
application menus include File, Edit, View and Help.  

MORE: 
Refer to Getting Started > Application Menus and Toolbars 

Application Toolbar 
A group of normally related graphical images that can be used for 
performing common actions in an application. The content of a toolbar 
normally reflects an associated application menu. In InForm Filler, 
application toolbars include File, Edit, View and Help. 

MORE: 
Refer to Getting Started > Application Menus and Toolbars 

Application Window 
The viewable area of an application. Contains the workspace where 
components such as menus, toolbars and the status bar are displayed.  

Arrow Keys 
Up, down, left and right direction keys found on the keyboard. In InForm 
Filler they can be used for positioning the text cursor when editing text, 
moving from one form element to another.  

B 

Bitmap 
An image such as a BMP or JPEG, composed of rows and columns of pixels, 
each of which can be a different colour or shade of grey.  
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BMP 
A bitmap file format. Can be imported using InForm Filler if an image is 
requested when filling in an InForm document.  

Bleed 
The part of a page that extends beyond the required printed portion of 
the page. It is commonly used when printing documents commercially to 
ensure the page image goes right to the edge of the paper after trimming.  

C 

Character 
Any letter, number, punctuation mark or other symbol. Also an InForm 
Designer property group heading for form elements such as text boxes, 
radio buttons and combo boxes.  

Click/Clicking 
Press the primary mouse button.  

Clipart 
Common term for graphical images such as a BMP, JPEG or EMF that can 
be imported into forms and used as page backgrounds and form 
elements.  

Clipboard 
A Windows® facility used to temporarily store information cut or copied 
from any application. Information is stored until other information is cut or 
copied to the clipboard.  

Context Menu 
A menu displayed alongside the mouse cursor when a form element or an 
area of the application is right-clicked.  

MORE: 
Refer to Getting Started > Context Menus 

D 

Double-click/Double-clicking 
Press the primary mouse button twice.  

DPI (Dots Per Inch)  
The resolution in dots per inch of a printer, scanner or bitmap. The higher 
the dpi, the smoother and cleaner a printed or scanned document or 
image is.  
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Driver 
Software that allows a computer to communicate with hardware or other 
devices. Without drivers, the hardware you connect to your computer - for 
example, a printer or fax - will not work properly.  

E 

EMF 
A vector file format. Can be imported using InForm Filler if an image is 
requested when filling in an InForm document.  

F 

Font 
A set of letters, numbers, punctuation marks and symbols.   

Form Element 
An element found in an InForm document that provides a visual reference 
point, instruction or facility for performing a form-based task. Examples 
include text boxes, labels, check boxes, radio buttons, combo boxes, 
images, buttons and shapes.  

Form 
An electronic or printed document that requests information from a user. 
Forms that can be used with InForm Filler and InForm Designer are called 
InForm documents and have an IFD file name extension.  

I 

IFD (InForm Document)  
The file name extension used to identify an InForm document that can be 
opened using InForm Filler and InForm Designer.  

InForm Designer 
A Windows® application developed by Fly Software for designing paper 
forms, e-forms and Web forms. Creates InForm documents (IFDs).  

Find out more from the following Fly Software web page: 

http://www.flysoftware.com/products/inform_designer/overview.asp 

InForm Filler 
A Windows® application developed by Fly Software for viewing, filling in 
and publishing InForm documents (IFDs).  

Find out more from the following Fly Software web page: 

http://www.flysoftware.com/products/inform_filler/overview.asp 

http://www.flysoftware.com/products/iform_designer/overview.asp
http://www.flysoftware.com/products/iform_filler/overview.asp


Glossary 

68 InForm Filler User Guide 

InForm Plug-in 
Form design tools found within InForm Designer that can be optionally 
licensed. A comprehensive range of InForm Plug-ins is available to satisfy 
many common form design requirements such as creating text boxes, 
labels and check boxes.  

Find out more from the following Fly Software web page: 

http://www.flysoftware.com/products/inform_plug-ins.asp 

Import 
To insert data, an image, PDF or other document within an InForm 
document.  

Installation Wizard 
A software mechanism for installing applications on a computer.  The 
process guides the user through procedures such as selecting the 
installation path, accepting terms and conditions, and creating Windows® 
Start menu and desktop icons.  

MORE: 
Refer to Getting Started > Installing. 

J 

JPEG (JPG) (Joint Photographic Experts Group)  
A common image format that uses compression to keep the size of the file 
to a minimum. Can be imported using InForm Filler if an image is 
requested when filling in an InForm document.  

L 

Label 
A text-based form element used to provide instruction and identify other 
form elements. 

Left Click/Left Clicking 
Press the primary mouse button.  

List Box 
Refer to Combo Box.  

http://www.flysoftware.com/products/iform_plug-ins.asp
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M 

Menu 
An element found within most applications that is used to display related 
and selectable options. Application menus and context menus are both 
found in InForm Filler.  

Mouse Pointer 
Indicates the position of the mouse on screen and used to select 
application components and form elements. Represented in InForm Filler 
by an arrow.  

Multiple Select 
To select multiple form elements.  

P 

Page 
The bordered area of an InForm document where form elements are 
displayed.  

MORE: 
Refer to Getting Started > Workspace Overview 

Page Bar 
Displays the page buttons used to change the page being viewed within 
an open InForm document.  

MORE: 
Refer to Getting Started > Workspace Overview, and Viewing Forms > 
Changing Pages 

Pica 
Printer’s unit of measurement commonly used in typesetting and graphic 
design. One pica equals approximately 1/6 of an inch.  

Pixel 
A coloured dot that makes up the smallest part of a bitmap. Also one of 
several units of measurement used in InForm Designer.  

Point 
A unit of measurement normally used to define type sizes. There are 
approximately 72 points in an inch and 12 points to a pica.  

Publish 
An action such as printing, faxing, exporting to PDF, emailing, or adding a 
form to a web page or other electronic media.  
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MORE: 
Refer to Publishing Forms. 

Publishing Device 
A printer, fax, PDF driver or other hardware or software where an InForm 
document can be output to.  

MORE: 
Refer to Publishing Forms. 

R 

Resize Handle 
A set of eight black dots that surround all selected form elements. They 
appear in each corner of the object and in the middle of each horizontal 
and vertical plane. Each can be used to resize the associated form 
element.  

Resolution 
Refers to the number of pixels per inch (ppi) or dots per inch (dpi), 
contained in a bitmap or the viewable area of a monitor. Low resolutions 
can result in a grainy or jagged image and larger screen objects; high 
resolutions can produce smoother and clearer images and smaller screen 
objects.  

Right-click/Right-clicking 
Press the secondary mouse button.  

S 

Scroll Bar 
An application component used to move the viewable area of a page, or 
to scroll vertically through a list of options in a combo box. 

MORE: 
Refer to Getting Started > Workspace Overview, and Viewing Forms > 
Moving About a Page > Using Scroll Bars. 

Shape 
A vector image such as a rectangle, ellipse or line. 

Shortcut Key 
Key or key combination used to perform an action or a command found 
on a menu. For example: Ctrl+A = press the Ctrl and A keys together.  
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Status Bar 
The horizontal bar found at the bottom of most applications. In InForm 
Filler it is used for displaying information about the selected form 
element.  

MORE: 
Refer to Getting Started > Workspace Overview 

Support Ticket 
The online mechanism for reporting any problem encountered when 
using InForm Filler or InForm Designer. Requires a Fly Software User 
Account.  

T 

Title Bar 
The horizontal bar found at the top of most applications. Used for 
displaying the application icon, application name, filename of the open 
document, and minimize, maximize/restore down and close (exit) buttons.  

MORE: 
Refer to Getting Started > Workspace Overview 

Toolbar 
Refer to Application Toolbar.  

U 

URL (Uniform Resource Locator)  
A unique address to indicate where a web page is found on the Internet. 
For Example: http://www.flysoftware.com/site_map.asp is the URL of the 
site map web page on the Fly Software website.  

W 

Watermark 
The FLYsoftware.com image displayed at 45° across all pages of InForm 
documents that contain form elements created using one or more 
unlicensed InForm Plug-ins. When all used InForm plug-ins are licensed, 
the watermark is removed from all pages.  

MORE: 
Refer to Getting Started > The Fly Software Watermark. 

Workspace 
The area within an application window where application components, 
are contained.  

http://www.flysoftware.com/site_map.asp
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MORE: 
Refer to Getting Started > Workspace Overview 

Z 

Zoom 
To reduce or magnify the view of a page within an InForm document. 
Zoom in to see the page detail more closely; zoom out to take a broader 
view. 

MORE: 
Refer to Viewing Forms > Magnifying or Reducing the Page View. 
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